Файловые менеджеры

Содержание

  • A43
  • AccelMan
  • Control3
  • DTree
  • FAR
  • Frigate (Фрегат)
  • PowerDesk PRO
  • Singularity 2000
  • SpeedCommander
  • Total Commander
  • EF Commander Free
  • Проводник
  • FreeCommander 2007.05a
  • Таблица сравнения
  • Дополнение

Хотя в любой ОС, имеется файл – менеджер «Проводник». Но он уже давно морально устарел и не имеет многих функций, как современные файловые менеджеры.

Лидерство принадлежат трем программам – стандартному Проводнику, дедушке FAR Manager, и, конечно, Total Commander.

Файловые менеджеры необходимы для удобной, эффективной и быстрой работы с файлами или папками (создание, копирование, перемещение, просмотр, редактирование, поиск, удаление и многое другое.)

A43 – 800 кбт- freeware Хороший файловый менеджер должен уметь как минимум самостоятельно работать с архивными файлами, просматривать графические файлы, иметь закладки и систему поиска. Все это можно найти в бесплатной, не требующей инсталляции программе A43. Внешним видом она напоминает Проводник: слева - дерево каталогов, справа – окно просмотра. Однако все ее органы управления вынесены на верхнюю панель. Еще одно достоинство A43 состоит в том, что в нижней части главного окна есть область, в которой можно открыть дополнительно папку, текстовый редактор или систему поиска.

AccelMan - Мощный файловый менеджер. Работает с ZIP- и SFX- архивами. Имеет встроенный мультимедиа-проигрыватель, воспринимающий как аудио-, так и видеофайлы. Поддерживает смену кодировок и "шкур". Имитирует схему интерфейса популярных файловых менеджеров.

Control3 - Быстрый файловый менеджер . Отличительная особенность это 3 панели вместо двух.

DTree - Многооконный файловый менеджер, облегчающий работу с файлами и их просмотр. Позволяет не только производить операции над файлами, но и просматривать графику и многое другое. Недостаток она может быть установлена только на Английском, Французском, Немецком и Датском языке. 304кбт

FAR – 1 385 кбт shareware Очень распространенный файловый менеджер, работающий в текстовом режиме. Классическая организация интерфейса в виде двух панелей с древовидной структурой отображения содержимого дисков. Как и в Norton Commander, есть быстрое выделение по маске. Поиск файла возможен по фрагменту имени файла, каталога или по фрагменту содержимого файла. Конечно же, имеется фильтр, но он довольно слабенький - по маске или набору масок. Из приятных мелочей присутствует возможность добавлять ссылки на папки для последующего быстрого доступа к ним по нажатию соответствующей комбинации клавиш. Нельзя не отметить широкие возможности настройки программы, в частности, интерфейса. Есть временная панель (как виртуальный диск).Окно можно плавно увеличивать по ширине или по высоте. (Cntrl+курсор). В целом же, это очень удобный и быстрый файловый менеджер со множеством настроек и функций. Файлы с разным расширением имеют разный цвет. Последняя версия 1.705

http://www.rarsoft.com/far_add.htm - Плагины к FAR Manager
http://www.uic.nnov.ru/~ruiv/plugring - Плагины к FAR Manager

Frigate (Фрегат) – 9 626 кбт shareware - 300руб.

Разработчики утверждают, что на сегодняшний день Фрегат является самым функциональным и самым мощным средством работы с файлами. Интерфейс действительно интересный, с обилием кнопочек, различных панелей индикаторов и всплывающих меню и очень удобно реализованным многооконным режимом. Выделение файлов доступно практически только самое простое - по маске. Правда есть возможность создавать список часто используемых масок и выделять файлы, которые не соответствуют определенной из них. Поддерживается групповое переименование файлов и каталогов. Возможности поиска самые обычные - по дате изменения, размеру, атрибутам и содержимому (для которого можно выбрать кодировку), но есть еще поиск и замена фрагментов содержимого в найденных файлах. С архивами Фрегат работает и самостоятельно понимает многие форматы. Есть часы и панель регулировки звука. При копирование файлов показывает скорость копирования. Просмотр почти всех файлов с различными расширениями: txt; rtf; doc; html; gif; jpg; tif; bmp; pdf и др. и все просматривает собственным просмоторщиком. Фрегат умеет работать с 24 графическими форматами. При нажатии клавиши F3 – определяет объем папки. Имеет свое меню и быстрый переход к папкам.

PowerDesk PRO - PowerDesk File Manager имеет графический интерфейс, который можно настроить как в виде классического "Проводника" Windows, так и в виде, напоминающем классические две панели. В программе предусмотрен поиск по атрибутам, сохранение параметров поиска, а также очень удобная функция присоединения результатов поиска. То есть к результатам поиска можно добавить файлы и каталоги по другому критерию и потом работать с образовавшейся группой файлов. Встроенная программа просмотра понимает большинство распространенных форматов текста и графики, а также таблицы Excel. При просмотре текста есть возможность выбрать кодировку, а при просмотре графических файлов картинку можно даже преобразовать в другие форматы, список которых весьма велик. PowerDesk File Manager умеет работать с различными архивами и cab-файлами, правда, многотомные архивы программа не понимает. Также имеется интересная возможность устанавливать произвольную дату создания и изменения файла и встроенный FTP-клиент.

Singularity 2000 - Файл-менеджер сочетающий в себе лучшее от Norton Commander и Проводника.

SpeedCommander – 4,93мбт shareware 18,5 $

Удобный файловый менеджер, поддерживающий большое количество форматов архивации. Содержит встроенные возможности по редактированию текста и подсветку HTML-кода. Позволяет просматривать графические файлы и имеет гибко настраиваемый интерфейс.

Total Commander –1 650 кбт

Вышла новая версия 6.55 Final

Программа Total Commander пользуется огромной популярностью среди пользователей во всем мире. Поддержка Unicode в названиях копируемых, перемещаемых и переименовываемых файлов. Учитывается эта кодировка и при сравнении текстовых файлов. Отдельный раздел опций отведен для определения параметров копирования. Встроенный в программу FTP-клиент умеет восстанавливать любые прерванные загрузки. Нажав сочетание CTRL-T, вы сможете открыть новую закладку в файловом менеджере. Использование этой функции позволяет запускать только одно окно Total Commander, экономя таким образом системные ресурсы.

Появились новые опции поиска, улучшена работа программы в операционной системе Windows Vista.

Содержит встроенный FTP-клиент.

Функции клавиатуры, близкие к оригиналу (NC для DOS).

Поддержка Drag&Drop при помощи мыши.

Внутренние распаковщики для форматов ZIP, ARJ, LZH, GZ, TAR, RAR и ACE, BZIP2 и PPMd.

По Alt+Shift+F3 внутренний просмоторщик загружается без плагинов и дополнительных возможностей обработки мультимедиа.

ОС: Windows 95/98/NT/ME/2000/XP/Vista | Многоязычный интерфейс | Shareware.

Скачать http://www.izcity.com/lib/31072006.htm

Total Commander 7.04a ExtremePack 2.95 Rus

Shareware, 99 мбт

Файловый менеджер Total Commander 7.04a Final с набором лучших плагинов и утилит. Total Commander (ранее WinCmd) — файловый менеджер для Windows™, наподобие Проводника Windows. Однако Total Commander использует иной подход: у него две постоянных панели бок о бок, как в хорошо известной DOS-оболочке (NC). В Total Commander присутствует встроенная поддержка архиваторов ZIP, ARJ, LZH, GZ, TAR, RAR и ACE, встроенный FTP-клиент, расширенные средства для работы с файлами и директориями (копирование, перемещение, удаление и т.д.). Total Commander работает с сетевыми дисками, поддерживает метод Drag&Drop, осуществляет запуск программ из командной строки с установленными параметрами. В файловый менеджер Total Commander можно подключить плагины, которые значительно расширяют его возможности. Есть возможность записи на DVD.

Намного больше возможностей, чем у Total Commander 6.55 Final

EF Commander Free
Freeware
610Кб
http://www.efsoftware.com/sw/efcwt.zip - EF Commander - полнофункциональный диспетчер файлов для Windows. Работа в многозадачном режиме, поддержка архивов (ACE, ARC, ARJ, BZIP2, CAB, GZIP, ISO, LHA, RAR, TAR, TBZ, TGZ, ZIP, ZOO, UU, XX, и др.), поддержка функции drag and drop, встроенный HEX редактор, синхронизация каталогов, многоязыковая поддержка, и многое, многое другое.

Проводник

Имеется во всех ОС и имеет ограниченное количество функций при работе с файлами.

Недостатки: 1.Не видно расширения файла 2.Не показывается объем файла 3.Копирование и перемещение файла неудобно для пользователя и затрачивается на это много времени.

4.Нельзя сразу посмотреть информацию о файле. 5.Нет собственного просмоторщика файлов.

6.Нет FTp.

Чтобы увидеть Расширение надо зайти в настройки "свойства папки". Снимаем соответствующую галку, и видны все расширения. Но это все равно не удобно для пользователя.

Можно включить вид "таблица", то становятся видны размер, тип и дата файла.

Просмотрщик - имеется, но он не сравнится ни с одним другим файл-менеджером. Если выбрать

вид "Эскизы страниц", то частично видно, что за картинки, например, лежат в папке.

Ftp есть конечно, но ограниченный, он позволяет только обзор и закачку, но не позволяет выгрузку на ftp. Чтобы попасть на ftp, надо написать его URL в адресной строке.

Из недостатков Проводника - он занимает 20МБ памяти, корявый поиск и, само собой,

двухоконные менеджеры все-таки удобнее для копирования/перемещения/удаления/создания

файлов.

FreeCommander 2007.05a

Опубликована новая версия двухпанельного файлового менеджера. Данная программа обладает большой функциональностью. С её помощью можно получить полный доступ ко всем файлам и папкам компьютера; копировать, перемещать, удалять, переименовывать файлы и папки, работать с архивами (ZIP, CAB, RAR), а также просматривать файлы в шестнадцатеричном, бинарном и текстовом виде. Интерфейс FreeCommander полностью настраивается и поддерживает технологию Drag&Drop. Из дополнительных функций можно отметить разделение и соединение больших файлов, поиск файлов (поддерживается поиск внутри архивов), сравнение и синхронизацию папок, просмотр и редактирование свойств файлов, работу с командной строкой, подключение к удалённым серверам. В новой версии стало доступно распаковывать JAR, WAR и EAR архивы, добавлены/изменены горячие клавиши.

ОС: Windows 95/98/Me/NT/2000/XP/2003 | Англ, русский интерфейс | Бесплатно.

Скачать (1613 кб): отсюда

Таблица сравнения

Файл - менеджер | Ftp | Занимаемая Память кбт | Drag& Drop | командная строка | Просмотр картинок | Просмотр Doc | Собствен- ное меню | Временная панель | Быстрые папки
FAR | + | 388 | + | + | - | - | + | + | -
Total Commander | + | 8 972 | + | + | Внешним просмотр. | + | + | - | +
Frigate (Фрегат) | + | 1 664 | + | + | + | + | + | - | +
A43 | - | 9 644 | + | + | - | - | - | - | -
EF Commander Free | - | 6 312 | + | + | + | - | - | - | -
Проводник | - |  | + | - | Внешним просмотр | - | + | - | -

К содержанию

Дополнение

File Navigator 1.72

File Navigator взял многое и от FAR Manager, и от Total Commander. Интерфейс программы выполнен в стиле Far, а многие средства для работы с файлами и папками напоминают те, которые есть в Total Commander. Скажем, при щелчке по заголовку панели открывается список папок, к которым можно получить быстрый доступ, щелчок по кнопке в виде стрелки, в правой части каждой из панелей, вызывает список недавно посещенных папок.

По-умолчанию можно просмотреть файлы в кодировках Windows, DOS, KOI8, UTF-8, ISO, Unicode, а также в формате RTF. Просмотр самых популярных форматов графических файлов (Bmp, JPEG, GIF, Ico, ICL, Cur, TIFF, Psp, Psd, Png, PCX, Targa), как и в Total Commander, реализован при помощи дополнений.

Есть также дополнения для просмотра ID3-тегов, видеофайлов AVI и информации о них (количество кадров и прочее), для просмотра файлов баз данных.

В окне менеджера файлы выделяются разными цветами, что довольно удобно, поскольку файлы гораздо проще искать. По-умолчанию, создано несколько групп файлов – графические выделяются одним цветом, архивы - другим, документы - третьим, но все цвета легко настраиваются, и можно создавать неограниченное число дополнительных групп. Отдельно задаются цвета для файлов, которые выделяются и на которые наводится курсор.

Unreal Commander 0.91

Работать с Unreal Commander достаточно удобно – кнопки для навигации по дискам на виду, кнопки для доступа к часто используемым и недавно посещенным папкам такие же, как в Total Commander. Проверка на горячие клавиши, а точнее, на их соответствие сочетаниям в Total Commander, прошла успешно – привычное CTRL+M вызвало окно пакетного переименования файлов, практически идентичное подобному инструменту в Total Commander. При нажатии ALT+F7 появилось окно поиска файлов.

Несомненное преимущество программы – поддержка плагинов для просмотра файлов (WLX) и для работы с архиваторами (WCX), которые написаны для Total Commander. Правда, над установкой дополнений автору программы следует ещё поработать. Если в Total Commander для установки плагина достаточно зайти в папку, где он находится, а затем утвердительно ответить на вопрос о необходимости инсталляции, в Unreal Commander плагин нужно собственноручно распаковать, а затем, в настройках программы указать путь к нему. Это, конечно, удобнее, чем подключение дополнений в File Navigator, но не так просто, как в Total Commander.

Unreal Commander имеет русский интерфейс и распространяется бесплатно. Скачать можно http://x-diesel.com/download.php?lgg=ru

JExplorer 1.8.0.1

Очень интересная корейская разработка, функциональность которой поражает, если учесть, что мы имеем дело с бесплатной программой. Кроме основных инструментов для работы с файлами, в JExplorer есть клиент для проверки почты по протоколу POP3, FTP-клиент, модуль для снятия скриншотов, а также инструмент для монтирования виртуальных дисков. Для создания такого диска нужно указать папку, содержимое которой будет отображаться в виде отдельного диска.

Удивительно выглядит наличие встроенного браузера. В него легко трансформируется одна из панелей или обе, если вам это покажется удобным. Для открытия сайта нужно щелкнуть по заголовку панели, где отображается путь к текущей папке, и ввести адрес сайта. Кстати, благодаря тому, что заголовок панели фактически является полем для ввода, копировать в буфер обмена пути к файлам и папкам очень просто.

При первом запуске программы программа покажет окно настройки, в котором нужно ввести данные для проверки почты, составить список FTP-серверов, настроить работу с архивами.

JExplorer распространяется бесплатно. Русского интерфейса нет, только английский. Скачать можно http://home.megapass.co.kr/%7Ewoosjung/Index_Download.html .

К содержанию

http://www.tst9.spb.ru                  = главная страница

http://www.tst9.spb.ru/p53.htm = бесплатные электронные книги

http://www.tst9.spb.ru/p10 = страница программы

Copyright © Денисов А.С. копирование и переиздание этого документа только с разрешения автора.